Veloclub Hub

I can’t seem to access the Veloclub Hub. It’s asking me to sign in when I’m already signed in. Any ideas what the issue might be?

I had this problem a while back. Andy Vanderbergen sorted it out via the Slack channel - I think I had to clear my cache iirc. That said, I just tried to access it now and got the same error as you :man_shrugging:

2 Likes

I just tried via mobile & was able to access. Android via Chrome 104.0.5112.97

1 Like

Apols - just seeing this now @callumdwyer - are you still experiencing the same issue?

Hi Andy, I am having the same problem trying to get access to the Hub.

1 Like

Yes I am

1 Like

Same problem for me.

Andy, I emailed about this earlier today.

1 Like

Oops, I guess I spoke too soon about solving my login issues on #support, I’m having the same problem with Veloclub Hub. The funny part is when it tells me I’ve run out of free articles and “Already a member? Sign in” Clicking on the Sign in link immediately shows my member info.

Edit: oh, never mind, though the member info page doesn’t indicate so, it looks like my membership has lapsed. :person_facepalming:

Well, now I’m looking for that CT+Strava deal again.

I am the same, maybe its a wider issue!